Kia Soul Forums :: Kia Soul Owners banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Suddenly this morning my front sprayer stopped working.
When I pull forward OR push back it sprays in the back. Nothing in the front. Was fine last night...I would understand it is was frozen and not working, but sending it to the back?? Any ideas other than service? :confused:
Thanks
 

·
Super Moderator
Joined
·
9,513 Posts
This is the intro forum. I have moved this to the prolem forum for a Gen 2 (since I don't know if you have a Gen 1 or a Gen 2, that may help get an answer). Welcome. If it turns out that you have a Gen 1, I will move it again.
 

·
Registered
used to own a 2016 Soul SX 2.0L - Caribbean Blue
Joined
·
15,165 Posts
maybe a line came off. Trace the lines to see what is happening. It still could be partial frozen, which can sometimes do strange things to the washer system.
Did you have full strength washer fluid in it (I use a -40C rating where I'm located) so no danger of freezing occurring.
 

·
Registered
Joined
·
2,332 Posts
Suddenly this morning my front sprayer stopped working.
When I pull forward OR push back it sprays in the back. Nothing in the front. Was fine last night...I would understand it is was frozen and not working, but sending it to the back?? Any ideas other than service? :confused:
Thanks
Duh! That's how the back washer works....you pull the handle toward you to operate the front washers, and you push the handle away from you to operate the rear window washer. If the front one doesn't work, it may be frozen. About May it should start working again.

Good Luck,
:cool:
 

·
Registered
Joined
·
215 Posts
It could very well be frozen and since the fluid comes from the same source it's probably just pushing the pressure through the rear sprayer. Take a hair dryer to your spray ports and see if it changes .
 
1 - 5 of 5 Posts
Top