Kia Soul Forums :: Kia Soul Owners banner

1 - 11 of 11 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1 (Edited)
Hello, Recently upgraded base "red" radio to 5" touchscreen, everything works fine except USB. I see the new radio has a separate USB connector on the back. Has anyone done this and worked a connection to factory USB? thanks, finkle

** UPDATE**

Originally bought the 5" touch screen with the "eServices" button on top right, with black USB connector on back. That one hooked up fine and worked, EXCEPT for the factory USB and aux input did not work. I attempted to directly solder USB connector onto the radio board, for the USB to work, but I somehow goofed up something and the volume knob on radio stopped working... I was not satisfied with this...

Ordered another radio from Ebay with the "Disp" button on top right corner, and a larger white connector on back in place of smaller USB connector. This one hooked up fine AND the USB and Aux both work. I did not hook anything to larger white connector, my car has nothing to hook to this connector, i'm guessing it's the amp connector...

USB and AUX did NOT work.
133313


USB and AUX DO work.
133314
 

Attachments

·
Registered
Joined
·
354 Posts
Hello, Recently upgraded base "red" radio to 5" touchscreen, everything works fine except USB. I see the new radio has a separate USB connector on the back. Has anyone done this and worked a connection to factory USB? thanks, finkle

I think the USB wiring was discussed within this thread:


If not give the Advanced Search a whirl. Others have had to address the USB wiring when swapping head units.
 

·
Registered
Joined
·
107 Posts
Hello, Recently upgraded base "red" radio to 5" touchscreen...
Which brand / model of radio?

Did you have to do anything special (wire in additional components, etc) to get the steering wheel controls to work with the new radio?
 

·
Registered
Joined
·
1,582 Posts
As I remember, and it was a few years ago, that was a single negative to upgrading the cheapo radio. May need to rewire it.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #5
Which brand / model of radio?

Did you have to do anything special (wire in additional components, etc) to get the steering wheel controls to work with the new radio?
Nothing at all. Plug and play, except for the USB and Aux connection at bottom/center of console.

this is the eBay link to what I bought.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #6
As I remember, and it was a few years ago, that was a single negative to upgrading the cheapo radio. May need to rewire it.
I messed with it today. Pulled a USB motherboard connector out of an old computer and hooked it up(had to hold it in place account it won’t snap in). It recognized my IPhone. So it’s a standard 4 pin USB layout/wiring on back of radio, Just need to find the factory connector and splice it in.
 

·
Registered
Joined
·
107 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #8
Well, I got impatient, no luck finding the wiring harness local or online so I pulled the radio out, took it apart and soldered the USB connection onto the motherboard. Works, reads my USB flash drive, recognizes my phone(tries to play pandora app?) however, my volume knob doesn't work now, still works on the steering wheel control, nothing else is near the USB port on the MoBo... I'm thinking maybe I didn't get the ribbon cable seated properly... Anyhoot, I don't see any advantage to doing this, I was able to move some music to the onboard Jukebox...

Does anyone have the latest update for the 4.5-5 touchscreen they would share with me? I registered with MyUvo, but beings the car came factory with the base radio, it doesn't give an option for an update.. thanks
 

·
Registered
Joined
·
476 Posts
There is a TSB for updating that base UVO headunit with eServices. Corrects a Loud Ringer Volume issue and improves bluetooth connectivity and voice recognition. Check to see what version your headunit is running on now. You need version 1.MP.1.001 or higher. Mine is 1.MP.1.007 (but Canadian non eServices version). The TSB updates to 1.MP.1.018 and describes how to do it.

There is another TSB that updates to .020 too that corrects a dark camera issue. Could be others too??
 
1 - 11 of 11 Posts
Top