Kia Soul Forums :: Kia Soul Owners banner

1 - 8 of 8 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Can anyone provide instructions on how to fill and check the transmission fluid level in a 2013 Kia Soul with an automatic transmission? I had to replace the transmission valve-body cover (the black plastic cover on the side of the transmission) due to a crack. I now need to fill the transmission to the proper level, but there is no filler tube or dipstick. Thanks in advance to anyone that can help.
 

·
Registered
Joined
·
1,780 Posts
I almost hate to ask .... Being a 2013 , Why didn't the dealer do the work ? Was it damaged in an accident ?

The Automatic transmission is sealed on the 2012 and up .
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Yes. Went through a big pot hole and the car bottomed out. The front corner of the cover hit something and developed a small crack that started leaking transmission fluid.
 

·
Registered
Joined
·
750 Posts
There is an oil level plug on the side of the valve body cover. You remove this plug and if oil drips out the level is correct. If it pours out it is overfilled, and if nothing comes out it is low. This is much like manual transmissions.
To add fluid, remove the eyebolt for the vent hose (up near top above the valve cover), and add oil through this hole. It is all on kiatechinfo.com, but maybe this will save folks some time.
Obviously the car needs to be level parked to do these checks..... and please use the correct transmission fluid, as it DOES matter!
 

·
Registered
Joined
·
750 Posts
Oops, and Duh, I forgot to mention the oil should be warm, and the engine on and idling when you do this check. Sorry!
 

·
Registered
Joined
·
1 Posts
New to forum

Just starting with your forum.
Just got a 2013 with 2 liter motor the engine and transmission were swapped from a similar model due to engine problems, both units had 55000 kilometres on them( approx 30000 miles)
With the new set up the engine runs fine but when the car is accelerating when it shifts up from second gear to third the trans drops into a passing gear then up shifts this does the same all the way up to top gear. Once there it runs fine. This,revs up the engine and cause quite a jolt as it shifts.
I have checked the trans fluid level and appears,ok

Any suggestions?
 
1 - 8 of 8 Posts
Top