Kia Soul Forums :: Kia Soul Owners banner

1 - 9 of 9 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
New to the forums, I have a question my friend has a 2013 Kia Soul. She says it seems like when she accelerates it doesn't have that umph and it's not properly switching gears?

What might be the problem, have anyone experienced this?

Thanks in advanced.
 

·
Registered
used to own a 2016 Soul SX 2.0L - Caribbean Blue
Joined
·
15,164 Posts
is this an automatic? If so, ask if she has the ACTIVE Eco button on and if that is the case tell her to turn it off and see what happens.
 

·
Premium Member
2017 KIA Soul base, Titanium. Bought some better taars.
Joined
·
2,639 Posts
After she turns the ECO button off, since it does nothing good anyway, show her how to stuff your foot into it.

What did she drive before this?
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5 (Edited)
Thanks for the reply's I have to ask her about that ECO button when I speak with her later tonight.

Also it's a 4cy Automatic. She says this problem just recently started, shes had the KIA alittle over a yr.

She drove a Pathfinder before this.
 

·
Registered
used to own a 2016 Soul SX 2.0L - Caribbean Blue
Joined
·
15,164 Posts
Thanks for the reply's I'' have to ask her about that ECO button when I speak with her latter tonight.

Also it's a 4cy Automatic. She says this problem just recently started, shes had the KIA alittle over a yr.

She drove a Pathfinder before this.
is it the 1.6L or 2.0L 4 cylinder automatic?
 

·
Registered
Joined
·
992 Posts
Make sure to check for proper trans fluid level. If trans oil is low, the car will display what you describe.
Greg
 
1 - 9 of 9 Posts
Top