Kia Soul Forums :: Kia Soul Owners banner

21 - 24 of 24 Posts

·
Registered
Joined
·
17 Posts
My oil light came on at just 22k miles. Turns out the dealer hadn't torqued the drain plug tight and it came loose (found on skid plate), emptying the motor of oil, while driving 55mph. Noticed it immediately and pulled of the road within a mile. Had it towed to local dealership. Refilled with oil and retorqued plug to spec. Ran motor for approximately 15 minutes with no adverse noise. Thought all was well. 20 Days and 1400 miles later, the motor began to knock on my commute home. By the time I made it home, you could hear the devistation within the motor. Dealership installed Reman motor under warranty. Long story Short.....Check Oil Regularly!!
 
  • Like
Reactions: westslope

·
Registered
Joined
·
284 Posts
Turns out the dealer hadn't torqued the drain plug tight it came loose..:confused:
Had a friend drive from Michigan to Florida after a quick stop oil change...dripping oil all the wayo_O
The drain plug was finger tight..loose! Luckily, we saw the oil slick in our driveway! Saved the engine anyway(y)
Doing my oil change from now on...:rolleyes:
 

·
Registered
Joined
·
8 Posts
I would check the oil level IMMEDIATELY. It is probably low.
If oil is at the full mark, then there is an oil pump issue or the oil pressure sensor/circuit is an issue.

Note: Although some vehicles have oil and coolant level sensors, generally the oil light indicates low pressure, not volume. Although, low volume could lower pressure if the pump sucks air.


Minimum pressure is only 7.1 PSI...scary!

When did you have the oil changed? Where did you have it changed? Some places like jiffy lube use poor oil filters and can cause this problem. However, I agree with the other reply check the oil level before driving it again.
 

·
Registered
Joined
·
17 Posts
My check oil light was "flickering" intermittently and the oil level was just fine. Dealer checked everything out and told me the instrument cluster was shot. I called BS. They told me they needed to order a new one and when it came in they had to pull mine, send it in to have the new one reprogrammed/synced with my mileage data etc, and then have it sent back to be reinstalled. I called even more BS. Not covered by warranty however my extended warranty did cover it. I was out a vehicle for 3 weeks because that's how long it took and extended warranty didn't cover a loaner vehicle. When I finally got it back, everything worked fine and haven't had a problem since, so there must have been something to it.
 
21 - 24 of 24 Posts
Top