Kia Soul Forums :: Kia Soul Owners banner
1 - 11 of 11 Posts

·
Registered
Joined
·
71 Posts
Discussion Starter · #1 ·
I just wanted to see if the following problem is unique to me or if other Gen 2 Kia Soul owners dealt with it...

I own a 2017 Kia Soul ! - love this car. My 5 year anniversary is coming up in a month. And have not had any notable issues except one. My Android Auto just flicks out and says something like "Can't read USB..." (something like that). The solution to this problem has always been, quickly unplug from phone and immediately plug it back in. The nature of this problem suggests it's a software problem. I've had this problem with 6 different Android Phones (the latest being a Google Pixel 6 Pro). And I've used several different cables. I read somewhere that I needed to verify I've got a USB 3.1 cable, so I got one off of Amazon and still have that problem. Does anyone else deal with this?

I've yet to see this problem with Apple Carplay. So I'm left wondering if it's a software problem. But, if it's a software problem, that would mean other users here would be dealing with it as well. So, is anyone else here dealing with this issue? If so, have a recommended fix?
 

·
Registered
2016 Kia Soul ! 2.0gdi
Joined
·
356 Posts
I have the same problem as well. It has happened with different phones and different cables as well. Common denominator seems to be the head unit, or software itself. It seems completely random too.
 

·
Registered
Joined
·
71 Posts
Discussion Starter · #3 ·
I have the same problem as well. It has happened with different phones and different cables as well. Common denominator seems to be the head unit, or software itself. It seems completely random too.
YES! I thought maybe bumps caused it, but no. Just... suddenly drops. One day I can make a one hour trip and have no issues. The next, can't get 10 minutes before it's disconnected twice. Think there's maybe a software update for the head unit?
 

·
Registered
2014 White Exclaim Tallahassee, FL
Joined
·
768 Posts
I have a 2014 with the upgraded audio that allows for AA. The only issue I seem to have is the touch screen doesn't respond on occasion when AA is used. I typically just press one of the hard-touch buttons surrounding the HU (Setup), then get back to the main screen of the OEM Nav screen on the left and AA on the right and then resume operation. I sometimes do have to disconnect the USB and back in, but that's pretty rare. I'm on a Pixel 4A w/Android 12. Could maybe try and contact company that Kia contracts out the bi-annual updates?

 

·
Super Moderator
2010 Exclaim
Joined
·
8,254 Posts
Android Auto works flawlessly on my Kenwood head unit with my Pixel 6 & the Samsung I had previously. Probably a software issue with the head unit.
 

·
Registered
2020 GT-Line Turbo Cherry Black
Joined
·
156 Posts
So - I had this issue w/ my 2015. Running a Pixel 5. Now I have a 2020 GT Turbo, my wife has a 2021 Soul Turbo... We both have Pixel 5's. Still loose the phone w/ Android Auto frequently, for no reason. I've tried other cables, longer, shorter, no difference.

I tried a friend of mine's Jeep that has AA - I linked up, my phone, my cables 100%. No issues. I think it's either the Kia head unit, or the USB plug / interface they use. Annoying as hell.

I love AA when it's up and running, it's a great app / feature. But the way Kia implemented it's a real pain in the ass
 
  • Like
Reactions: Buzz

·
Registered
Joined
·
71 Posts
Discussion Starter · #8 ·
Now I have a 2020 GT Turbo, my wife has a 2021 Soul Turbo... We both have Pixel 5's. Still loose the phone w/ Android Auto frequently, for no reason. I've tried other cables, longer, shorter, no difference.
Man, you'd think they'd have had this resolved in the newer Gen3 versions. Guess not. That's depressing.
 

·
Registered
Joined
·
6 Posts
I normally have no problems on my 2022 GT, but my husband's phone won't stay connected. He might get a new phone because it's old (for a phone). We've switched cables and nothing. His phone charges fine at home.
 

·
Registered
Joined
·
71 Posts
Discussion Starter · #10 ·
For any future people looking for a solution, I went through the process to update my navigation (you're updating the head unit software essentially) I have resolved this ongoing Android problem. I updated it over a month ago and have not had a single drop since. So if you are having constant drops, update the head unit software.
 

·
Registered
2014 White Exclaim Tallahassee, FL
Joined
·
768 Posts
Updating the Kia Navigation system is so much easier these days once you have the program downloaded to your PC. I have two 32GB memory cards these days; one that's in the HU and another to circulate so there's always the previous version in case something goes haywire.

Most recent update came out the end of last month:

 
1 - 11 of 11 Posts
Top