Kia Soul Forums :: Kia Soul Owners banner
21 - 25 of 25 Posts

·
Registered
Joined
·
8 Posts
Can't do that I moved to Wisconsin I had that done in Texas. 🤦🏼‍♀️
I am not sure if I mentioned all this happened after I put gas in yesterday....
I thought this sounded familiar. Then you mentioned filling gas...

I had something similar happen once. I filled up with gas and started driving and things were fine. Then I started losing power. Then I stopped for lunch and couldn't get hardly any power. I finally gave up shortly after I got on the interstate onramp. I then used a friends AAA to get it towed about 100 miles to my mechanic. When they looked at it, they discovered fuel in the charcoal canister.


They were kind enough to empty the fuel, but failed to reconnect the hoses, and I got an CEL. When I got home I reconnected the hose and it has run fine since.

At least its a fairly easy thing to check.
 

·
Registered
Joined
·
14 Posts
So on my way home from work on freeway I noticed my car was not wanting to speed up when I stepped on the gas it wouldn't go. Now it's not going at all maybe 2mph. It's not accelerating. Also when I'm stepping on the gas it's extremely hard not to stop. I don't know if I'm explaining this well. Any suggestions
Camshaft position sensor. Had the same thing with my 2012 Soul. Long story but I had to diagnose myself ( dealership mechanics were worthless for the 10 days they had my car! ) I’ve driven it 40,000 more miles ( and going strong) and never a problem since it was replaced.
 

·
Registered
Joined
·
14 Posts
So on my way home from work on freeway I noticed my car was not wanting to speed up when I stepped on the gas it wouldn't go. Now it's not going at all maybe 2mph. It's not accelerating. Also when I'm stepping on the gas it's extremely hard not to stop. I don't know if I'm explaining this well. Any suggestions
Sorry, it is the crankshaft position sensor ( not camshaft!)
 

·
Registered
Joined
·
7 Posts
So on my way home from work on freeway I noticed my car was not wanting to speed up when I stepped on the gas it wouldn't go. Now it's not going at all maybe 2mph. It's not accelerating. Also when I'm stepping on the gas it's extremely hard not to stop. I don't know if I'm explaining this well. Any suggestions
could be several things. Among the things I would check would be to see if the catalytic converter is plugged
 
21 - 25 of 25 Posts
Top