Kia Soul Forums :: Kia Soul Owners banner
1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Sup boys, normally good with this stuff but I'm super confused right now because I have the adapters and double checked the pins are right but I'm still getting no sound from the android head unit.

I have the higher 2011 model and I've read online it may be due to the sub or amp?

This is the head unit in question:


Some pics


Hand Gesture Finger Thumb Nail

Arm Leg Glove Human body Finger

Hand Gesture Finger Electrical wiring Carabiner

Font Vehicle Motor vehicle Gas Audio equipment

Hand Gesture Electrical wiring Thumb Wrist

Finger Wrist Rock-climbing equipment Elbow Nail

Hand Gesture Finger Rock-climbing equipment Carabiner
 

·
Registered
Joined
·
2,316 Posts
Easiest way to test, assuming you know what pins go where, is to grab a spare speaker (or yank one of yours) and jumper directly from the head unit pins to the speaker. That will bypass everything else in the system. No sound means something is miswired or dead on the head unit.

Don't be too sure the head unit isn't faulty. Years ago, when I first got out of the service, I used to be an electronic technician for a car audio place. There was a surprising number of new, out of the box units with dead amps or other circuitry. This is going back 30 years ago, but there wasn't much coming from China back then either with most units either from Japan or South Korea.
 

·
Registered
2022 Kia Soul X-Line Gray
Joined
·
74 Posts
1 - 3 of 3 Posts
Top