Kia Soul Forums :: Kia Soul Owners banner

1 - 9 of 9 Posts

·
Registered
Joined
·
71 Posts
Discussion Starter · #1 ·
So, having a job that puts me in my car for hours a month (home office, but lots of customer visits), I decided I wanted to clean up all my mounted crap, both personal and work.

I run a tablet for nav, and other stuff that i also use for some work related hardware (stuff we sell and I support) that plugs into the ODBII port.
I also rely heavily on goolge maps, Torque, my hands free calling, etc., etc..

Here is what I just bought:

Kenwood DDX9703s
Sirius Ant
iDatalink Maestro RR
wire harness (metra)
the 12V to 6v stepdown for the backup cam.

Only thing I could not find in stock was a damned dash kit. :uncomfortableness:...like there are not 1.87 million 2014 and up Kia Soul running around the Dallas area. Amazon says one will be here Tuesday.

I got the Maestro updated with the proper firmware, and setup my steering wheel controls to match OEM, and someother options ( holding vol ^, will open Navigation, stuff like that).

The Maestro does not have any adaptors, so I will have to go to the car side of a couple of plugs and right to the head unit, no biggie.

Only thing I am curious about is using the OEM handsfree mic. I can hack the Kenwood wired mic and splice that into the OEM so I can use it. Has anyone tried that?

Also, if anyone has used the Maestro for TMPS, and other stuff on a Kia Soul +, what have you done?
 

·
Registered
Joined
·
484 Posts
If I could find the dash kit that Crutchfield sent to me I'd sell it to you. I just wrapped up an install on my wife's '16 over the weekend with an Amazon sourced Scosche kit. The Metras were sold out.

Mine's a base, and I think the mic was in the head unit. I didn't see any wires for one plugged into the OEM head- I stuck the Pioneer mic under the lower part of the dash pointing up through the steering wheel. Seems to work well for most of my cars, plus keeps the adhesive away from direct sunlight, so it survives Texas head.

So far LOVE Android Auto.
 

·
Registered
Joined
·
71 Posts
Discussion Starter · #3 ·
what a PITA.

Outside of the cam and Maestro all is done.

I did not have an RCA jack laying around, so I skipped that until my dash kit comes in.

Sat Radio, Android Auto, everything else works...almost threw the Maestro across the yard.
Wired it up exactly how they say and nothing works, NOTING :miserable:

Not sure if I am gonna send it back and just get a regular steering wheel adapter.
 

·
Registered
Joined
·
71 Posts
Discussion Starter · #5 ·
Yes.

I did make some headway. Evidently the T connectors suck. Got the steering wheel controls working.
I will re-tap the CAN connectors this AM.

Camera and mic .....I used the Kenwood mic as there is not a whole lotta room for taping the OEM connector.

I will work on the cam this weekend.
 

·
Registered
Joined
·
176 Posts
TruckinThumper, what are you tapping into the wires with? I did an install last week and I used posi-taps. They work very well and are better than other taps. I will use them from now on in any install requiring tapping into wires. They are available on Crutchfield and Amazon.
 

·
Registered
Joined
·
71 Posts
Discussion Starter · #7 ·
TruckinThumper, what are you tapping into the wires with? I did an install last week and I used posi-taps. They work very well and are better than other taps. I will use them from now on in any install requiring tapping into wires. They are available on Crutchfield and Amazon.
Thats new to me! I am digging those!

THANKS SIR!

Off to Amazon :nevreness:
 

·
Registered
Joined
·
71 Posts
Discussion Starter · #9 ·
Well,

I got everything setup the way I want except for the F'n backup camera.
I am not sure what is different, but I cant find the feed leads.

If I use the diagram here Kia Soul: Audio Unit Components - Audio - Body Electrical System - Kia Soul 2014-2018 PS Service Manual
It will not work.

So, I hook up the OEM radio, plug in connector A and B, no feed, plug in the other (USB) plug and I get the feed.
According to the above link, that is not right.

No, I do not have the UVO.

I have the + Designer Package.

I am at a loss
 
1 - 9 of 9 Posts
Top