Kia Soul Forums :: Kia Soul Owners banner
21 - 36 of 36 Posts

·
Registered
Joined
·
43 Posts
I've never had a vehicle with onboard navigation - seems crazy to me to have to have the engine running for that long just to do an update. Versus say turning the key to the on position and going back in the house and watching a movie.

Is this - engine needing to be running - typical for updating onboard nav systems?
Yes, put gas in it, start it , ...and stay with the car, that time is normal and his method was correct... oh yeah don't forget your phone , its best not to touch any buttons while doing this.
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #22 ·
Well, I just loaded it on my Soul, 10.25 screen. It took 1 hour 11 minutes to update the radio and navigatio. The radio works and has kept, as best I can tell, all my presets. I kept the engine running for the entire proces.
Glad it worked for you. This reenforces my stance that it's not the software , but bad radios
I've never had a vehicle with onboard navigation - seems crazy to me to have to have the engine running for that long just to do an update. Versus say turning the key to the on position and going back in the house and watching a movie.

Is this - engine needing to be running - typical for updating onboard nav systems?
It's required because of the battery saver software built into the vehicles onboard computer. It will automatically shut the power off to save the battery if you leave something on.
 

·
Registered
Joined
·
6 Posts
Hey! Newbie here. Just replaced my ‘18 Soul EV with a ‘20 Soul EV (both canadian spec).

The 2020 has this as far as nav software versions :

SW : SK3EV.CAN.S5W_M.VO03.002.190813
FW : SK3EV.CAN.291.190614.MICOM.D
App : STD5W.NAM.KMC. 190603.88dad734
Map ver : NAM.12.47.44.510.205.3

Been trying to install a current release using the Kia Nav Updater app. I’ve created 3 different USB keys and tried every method I could see (Regular, Quick and the Scheduled options). I just always reach the same crappy result.

This screen comes up, it blinks to black and back endlessly. If I pull the flash drive out, that screen stops blinking and a progress bar fills up in red (Even though there is no USB inserted). Nothing happens after that (I’ve let it run for over 6 hours).

I did the soft reset multiple times (with the small pinhole button). Next step is probably to disconnect the car’s 12V battery for 30+ minutes like recommended on the Kia Navigation website, but that’s a risky step it seems.

Any advice?

Font Gadget Display device Darkness Multimedia
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #24 ·
It's not anything you are doing. There's a problem with the update software. KIA is aware. I have been in touch with KiA support through email and phone calls, and have been told that they are working on a solution, and will release a service bulletin to dealers when it's done. 60 to 90 days out, possibly sooner. What I don't understand is why they don't take down the online update instead of letting customers trash their radios.
 

·
Registered
Joined
·
6 Posts
Wow, thanks for that CEarley!

Putting that project on ice. Who knows, maybe I’ll just keep my 3 widget homescreen navigation software for good! I hear the new interface is quite bad.



It's not anything you are doing. There's a problem with the update software. KIA is aware. I have been in touch with KiA support through email and phone calls, and have been told that they are working on a solution, and will release a service bulletin to dealers when it's done. 60 to 90 days out, possibly sooner. What I don't understand is why they don't take down the online update instead of letting customers trash their radios.
 

·
Registered
Joined
·
43 Posts
Hey! Newbie here. Just replaced my ‘18 Soul EV with a ‘20 Soul EV (both canadian spec).

The 2020 has this as far as nav software versions :

SW : SK3EV.CAN.S5W_M.VO03.002.190813
FW : SK3EV.CAN.291.190614.MICOM.D
App : STD5W.NAM.KMC. 190603.88dad734
Map ver : NAM.12.47.44.510.205.3

Been trying to install a current release using the Kia Nav Updater app. I’ve created 3 different USB keys and tried every method I could see (Regular, Quick and the Scheduled options). I just always reach the same crappy result.

This screen comes up, it blinks to black and back endlessly. If I pull the flash drive out, that screen stops blinking and a progress bar fills up in red (Even though there is no USB inserted). Nothing happens after that (I’ve let it run for over 6 hours).

I did the soft reset multiple times (with the small pinhole button). Next step is probably to disconnect the car’s 12V battery for 30+ minutes like recommended on the Kia Navigation website, but that’s a risky step it seems.

Any advice?

View attachment 140945
Do the battery thing for an hour, make sure you car is running , turn off that fuel saver button.. it shoudnt take any more than 2 hrs maxx
 

·
Registered
Joined
·
43 Posts
Thanks, I’ll adapt those tips to my EV next time I decide to try this again.

What happens when we unplug the 12V battery on an EV? What data gets erased?
I don't know , but you are not supposed to leave it with out a charge long ....they have battery tenders that keep the computer going with charge when some batteries are changed , be careful...
 

·
Registered
Joined
·
6 Posts
The (hopefully fixed) update has been reposted today, if anyone would like to give it a try.

I'm downloading it now.
Well, this new release actually installed correctly on my car on its first attempt. It did take a bit over 2 hours to complete and delete all of my settings in the process however.

The interface is a bit slower than it used to be ( I had the original black/orange GUI) but the radio app seems much improved.

Holy Batman that's a lot of purple and pink!
 
21 - 36 of 36 Posts
Top