Kia Soul Forums :: Kia Soul Owners banner

1 - 11 of 11 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Here's the deal, both my low beams does not work, but however the both high beams & both markers light works, I don't switch out brand new bulbs and it's still doing the same thing. Any idea what the problem is?????

Thanks,
 

·
Registered
Joined
·
8,359 Posts
i would suggest it is still a bulb problem, maybe as one failed the power surge to the other took that one out too?.
 

·
Registered
Joined
·
1,149 Posts
Check fuse's, I belive there is a low beam fuse & Hi beam fuse

Dealer warranty issue ?

:)
 

·
Registered
Joined
·
2 Posts
Discussion Starter #4
I'm thinking is not the bulb but I could be wrong, but yeah Imma check on the fust, I didn't know there was a low & high beam fuse, well I also took it to Kia dealership cause is still under the bumper to bumper warranty but if it's not cover under warranty is going to be 75 bucks just to look at and plus the problems fees.

Check fuse's, I belive there is a low beam fuse & Hi beam fuse

Dealer warranty issue ?

:)
 

·
Registered
Joined
·
165 Posts
I have changed 2 headlight bulb and 4 fog (all burned) since I own my Soul bought in October 2010, and yesterday they gave me another H4 bulb. No charge !!! at 105$ each.............


Robert (bulb burner !!!!):laughonfloor
 

·
Registered
used to own a 2016 Soul SX 2.0L - Caribbean Blue
Joined
·
15,163 Posts
I have changed 2 headlight bulb and 4 fog (all burned) since I own my Soul bought in October 2010, and yesterday they gave me another H4 bulb. No charge !!! at 105$ each.............
$105.00 for one bulb!!!!!!!!!!!!!!!!!!!!!!!!!!!!! :confused:
 

·
Registered
Joined
·
915 Posts
The bulbs are on the bumper to bumper warranty inclusive the battery is under your B to B warranty, it's not normal that the bulb burn so fast, and it's weird that your dealer doesn't want to change it, in my opinion they just want to take advantage of your good faith.
 

·
Registered
Joined
·
878 Posts
The bulbs are on the bumper to bumper warranty inclusive the battery is under your B to B warranty, it's not normal that the bulb burn so fast, and it's weird that your dealer doesn't want to change it, in my opinion they just want to take advantage of your good faith.
I agree - if they want to keep you as a loyal customer for future service they should troubleshoot and replace the bulb as needed (no charge). If they nickel and dime you at the start, it's not a good sign for the future when you could possibly have more severe issues.
 

·
Registered
Joined
·
12 Posts
I'm having the same issue with my 2013 2u - all of a sudden both low beams are gone, high beams still work - checked fuses, there's a H/LP LH and H/LP RH 10amp fuse in the engine fuse box, and H/LP and H/HP Relays - fuses are good, swapped the relays, still no low beam, high beams still working. Seems to also be an issue with the right rear tail light connector at the taillight assembly as I was having issues with taillight, backup light alternating with the turn signal light when the right indicator was on, and only when the headlghts were on. appear to have the taillight issue bandaid fixed for now. but still no lowbeams.

Still under warranty until October 2018...

Ideas?
 
1 - 11 of 11 Posts
Top