Kia Soul Forums :: Kia Soul Owners banner

1 - 7 of 7 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
My 2011 Soul left front low beam not working. Hi beam is. Fuses all good. Any ideas why not working. Still under warranty. New bulbs.
 

·
Premium Member
Joined
·
4,959 Posts
It's possible there's a bad connection somewhere, but I would pull the bulb and check that before delving in any deeper.
 

·
Registered
Joined
·
1,129 Posts
Well if bulb replacement is out of your reach go to a Checker Oriley/ AutoZone / type place and ask them for help . They will sell you a bulb and probably put it in for you !
 

·
Registered
Joined
·
479 Posts
Sounds light the low filament went out. The 2011 has a dual filament bulb and it's very possibly (and pretty likely) that you just need a new bulb.
 

·
Registered
Joined
·
1,149 Posts
What do you mean by New Bulb's ?

Why did you have a bad bulb before, or just upgraded ?

Sound's like a bad bulb, New bulbs can be bad too.....

Look @ the bulb with a light & magnifier glass & check both filaments

You can also swap left to right bulbs & see if problem follows bulb or particular side of car

Let us know what you find out
 

·
Registered
Joined
·
2 Posts
Discussion Starter #7
Hey thats a good idea! will have to try it. I just bought the bulbs a few weeks ago. At first the hi beam didnt work, went back got a replacement bulb and still no hi beam. Then I noticed it was not working at all. Took it to a mechanic and now I have a hi beam but no low beam!
 
1 - 7 of 7 Posts
Top