Kia Soul Forums :: Kia Soul Owners banner
1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hi all! As the title says, I had my Soul professionally detailed today and she looks fantastic. But, when I got in to drive, the radio was blaring at level 25 and the volume knob did nothing. I turned it off. Randomly, the radio will turn on and start scrolling through the channels, then go into iPod mode, then Sirius XM. Did they maybe get something wet and it just needs to dry out, or is this a common issue?
Thanks for your input!
 

·
Registered
2016 Kia Soul ! 2.0gdi
Joined
·
242 Posts
Sounds like they definitely used something too wet, either sprayed on, or a really wet cloth to clean the radio. I should leave it powered off for a few days, and maybe try putting it in a garage with the windows open and a dehumidifier running if you can.

Sent from my SM-G935V using Tapatalk
 

·
Registered
2014 Titanium Stick Shift Pacific NW
Joined
·
7,935 Posts
If there's a reset on your radio give that a poke.

Maybe try disconnecting the battery for about 5 min and see if that gives it the Linda Blair treatment.
 

·
Registered
Joined
·
262 Posts
Sounds like too much wet; also learned a long time ago that you never spray Windex with Ammonia on the lenses of your gauges; that will definitely cloud plastic lenses; better to use a water dampened cloth (very little water) to wipe away the dust.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #5 ·
Sounds like they definitely used something too wet, either sprayed on, or a really wet cloth to clean the radio. I should leave it powered off for a few days, and maybe try putting it in a garage with the windows open and a dehumidifier running if you can.

Sent from my SM-G935V using Tapatalk
Thank you! Left it in garage with windows open the rest of the weekend and it’s now working fine again😊
 
1 - 6 of 6 Posts
Top