Kia Soul Forums :: Kia Soul Owners banner
1 - 12 of 12 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
2010 Kia Soul Exclaim. Front End Knocking both sides driving me nuts. This car has
1. New Struts
2. New Sway bar links
3. New sway bar bushings
4. New passenger motor mount
5. New torque strut mount
6. New lower control arms
7. New transmission mount going in this weekend.
8. New tires
9. Wheel alignment is done and perfect
10. New rear shocks also.
I strongly feel it is the stuts and in particular the way the Gen 1 stuts are mounted. I have had the struts in and out at least 6 times. I am feeling that the original struts had much softer rubber dampners. Other than this crazy knocking this car rides like it is new. The clunking happens at all speeds and seems to follow the travel of the strut. It is less noticable when driving fast. I really feel its the struts and i need to modify the dampening or retrofit the struts that come on gen 2 Souls. Please help. Thanks
 

·
Registered
Joined
·
1,654 Posts
Did you use quality parts? My cheapo TRQ struts in my 2011 Soul didn’t even last a year. Or maybe your noise could be coming from a loose exhaust?
 

·
Registered
2016 Kia Soul
Joined
·
25 Posts
Is everything torqued to spec? If not, go back and torque everything. A defective strut mount bearing could also be the culprit. Does it make that noise when you bounce the car by hand?
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #6 ·
Hi everyone and thanks for the replies. Everything in the front end has been torqued and retorqued and torqued again. I even tried playing with the top insulator cap, leaving it a little loose and then tightening it to specs. The sound changes when I do not. It almost seems to me like the insulator is too hard and that there is not enough cushion against strut tower.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #7 ·
I would love to see what stock insulators feel like. I am about to start changing the trans mount right now. The exhaust it not hitting anything either. I have spent hours and hours staring at everything under the car. I even disconnected the sway bar links just to eliminate it as the cause.
 

·
Premium Member
Joined
·
236 Posts
Lower nut under the strut cushion tight? And the top one?? I had a "click" on the passenger side thought it was a bad tie rod but it was the top bolt above the cushion on the OTHER side the morons didn't tighten it correctly after a alignment LAST year... I know you checked but just asking as both require a good amount of torque. Otherwise jack her up and start tugging. And have somebody jerk the wheel while your looking under there. Something has to make a noise while your under there! Also did you check the bolt at the bottom of the steering connection near your feet?
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #12 ·
Hey thanks so much for your reply Octavf. I have tried getting it to make the noise while on jack stands and boucing the car by hand but it only make the noise when either tire hits a bump. When i up my driveway kinda slow it will do it also. If i make a left into my driveway it does it much more than if i make a right up driveway. Could it be axle moving in and out??? I just installed the new transmission mount a few hours ago and though i am glad it is now in, it did nothing to solve the problem. Steering coupler seems to be silent also
 
1 - 12 of 12 Posts
Top