Kia Soul Forums :: Kia Soul Owners banner

61 - 80 of 94 Posts

·
Registered
Joined
·
1,331 Posts
I've removed the SD card half dozen times now. No love. I guess I'll try a reset.

Sent from my SM-T820 using Tapatalk
Be sure you are following the way I posted. I just got back from helping friends with a Sorento having the same problem. They switched SD cards with the radio on and it did not take. Doing it the way I posted and waiting each time worked. Reset might also work.
 

·
Registered
Joined
·
1,331 Posts
My 2015 Exclaim Primo package also lost the clock (I noticed yesterday). Removing and reinserting the SD card also worked for me :)

Now my remaining question is WHY did this happen? I think it's sooooo weird. Are we getting updates to the onboard Navi/UVO system without knowing it?
I don't think it was an update because too many different models across both companies had it happen. That tells me what I posted above is very likely. The clock data had a hiccup or was corrupted and the clock "app" needed to be reset to see the data again. Just like if we lose the internet every once in awhile I have to turn off and back on a device to get it to reconnect. Or no different than needing to reset a computer once in awhile or even a cell phone to correct problems.
 

·
Registered
Joined
·
4 Posts
My 2017 Sportage SX having the same issues 2 days ago..

Apparently it's something through the GPS and the satellite radio happens roughly every 6 years. I guess when they are flashing something in their system for the satellite or whatever it happens. Kia knows about it and there's going to be a service bulletin issued shortly. I was told 2 be out in the open and with the car running hold the small reset for 60 seconds and there's a good chance that everything will come back to normal.
 

·
Registered
Joined
·
4 Posts
Sorry I can't find the post edit tab. I was able to fix mine 2 days ago by removing the interior fuse panel cover and slipping the small blue power switch to the off position. That switches for transport mode which kills a lot of power to the accessories. I was actually able to press the start button and the engine started up and when I spoke to the service department and told him about the small switch, that's when they explain to me that is for transportation. Give it a shot and see if it works.
 

·
Registered
Joined
·
3 Posts
My clock stop working today also everything else is working but like someone else said the other function for the clock are grayed out.. can some help me with this.. Or should I disconnect the battery to see if that works.... HELP !!!! David
Mine too! Went out today!
 

·
Registered
Joined
·
10 Posts
Same thing happened to me (including the odd date).
However, this had been preceded for me by a couple months of the clock showing --:-- each time I started the card for a minute or two. The time would eventually display, but if I started the car underground it wouldn't come up until I was on the surface and presumably it got an updated time from the satellite. Whenever it finally synced up the time, it would disconnect Android Auto & I would have to physically unplug the phone cable and plug it back in.

I decided to try reinstalling the headend software this weekend, before I saw this thread. I went to "software update" and it warned me that the version on the SD card was already installed, but let me proceed. This fixed the issue I've had for the last few months & also the issue from this weekend.

For those having trouble getting the time back by removing the SD card, this may be an alternative solution. Not sure if you'll get that option if you've never installed a software update (eg the Android Auto update) but it worked for me!
 

·
Registered
Joined
·
4 Posts
Why hasn't Kia said anything
They have, they told me!:cool:

If you power cycle the system it's going to work. Removing the SD card and reinserting it will reboot the system but from what I understand from my sources is it may just be a temporary fix and again Kia does know about it and they will be issuing a service bulletin very soon.
 

·
Registered
Joined
·
1,331 Posts
They have, they told me!:cool:

If you power cycle the system it's going to work. Removing the SD card and reinserting it will reboot the system but from what I understand from my sources is it may just be a temporary fix and again Kia does know about it and they will be issuing a service bulletin very soon.
What does "power cycle the system" mean? Reset it?
The SD card resets the clock which is the only thing needed to be done according to the KIA dealer where I am at the moment in Ct.on a trip just having an oil change. Kia dealers are doing the SD card removal as witnessed by many online posts, youtube videos etc and what this one would have done if I had not already figured that out. You could try resetting the the system and needing to reset everything again but why do that if not needed? (Dealer words) Because of what caused this, I am skeptical once the clock is working again that it won't later unless the same incident happens again. I guess I am saying not sure what your source is saying just doesn't ring true to me.
But time will tell! (See what I did there....:) )
 

·
Registered
Joined
·
4 Posts
What does "power cycle the system" mean? Reset it?
The SD card resets the clock which is the only thing needed to be done according to the KIA dealer where I am at the moment in Ct.on a trip just having an oil change. Kia dealers are doing the SD card removal as witnessed by many online posts, youtube videos etc and what this one would have done if I had not already figured that out. You could try resetting the the system and needing to reset everything again but why do that if not needed? (Dealer words) Because of what caused this, I am skeptical once the clock is working again that it won't later unless the same incident happens again. I guess I am saying not sure what your source is saying just doesn't ring true to me.
But time will tell! (See what I did there....:) )
LOL no worries, if the dealership automatically removes the SD card that's great. When SD card is reinserted it causes the radio to do a complete reboot.

And you ask about my source? Mysource is my local Kia dealership plus the regional manager and also me.... I'm their Royal thorn in their ass when it comes to issues. They are very quick to keep me updated... They cringe when I walk through the door and I also cringe when I walk through the door because I have better things to do with my time then deal with issues such as this clock problem. ;)
 

·
Registered
Joined
·
3 Posts
Got mine to work by disconnecting the (+) positive terminal on battery and reconnecting.
With so many people having this issue at one time, it is disappointing Kia management (not dealership) hasn't notified customers of this issue and possible fixes.
 

·
Registered
Joined
·
93 Posts
This happened to me today. I fixed it by pushing in on the "reset" button (the tiny little button in the upper righthand corner) with the tip of a pin for a few seconds. After the system rebooted, the clock was blank for a minute, and then the time showed up as usual. The reset didn't affect any of my settings, and it even resumed the song it was playing on the USB drive.
 

·
Registered
Joined
·
768 Posts
These are the instructions I posted with but with more detail and has a better chance of working. I do NOT recommend taking the SD card out or replacing it while the radio is on. I realize some have had not problems doing it.
1. Start with the radio OFF.
2. Take out the SD card
3. Start the radio and wait.
4. There will be a notice there is no SD card inserted or something similar. Wait.
5. It then should say it is changing the display, that is the key. It should change the display showing no navigation and the clock should return at that point.
6. Turn off the radio.
7. Insert the SD card
8. Start the radio and all should be ok after it gets loaded again.
I tried these steps and other variations several times. I tried again this morning with no luck. After that, my wife and I went to visit her mom. When we left there, the clock was back. Unfortunately I'm back to being 60 instead of 10 :confused:
 
61 - 80 of 94 Posts
Top