Kia Soul Forums :: Kia Soul Owners banner

1 - 6 of 6 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
i'm trying to set up the bluetooth feature in my new soul but am having trouble getting started. after i press the bluetooth button, a message comes up saying "system not ready. please wait a moment"
i may be doing something wrong. i have no idea. am i skipping a step or something?
 

·
Registered
Joined
·
98 Posts
Have you paired the phone yet? You can get there using the 'Setup' button on the radio. If I remember right, you want to choose 'PHONE' and the 'PAIR'. Oh, I learned this the hardway, make sure the Bluetooth is ON in your phone.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
thanks for your help. i tried everything yesterday and ended up calling the kia help desk. it turns out that there's something wrong with my soul :( and that i have to take it back to the dealership to see if they can get it working.
 

·
Registered
Joined
·
3 Posts
Hello,

Nice to find an already existing thread about Bluetooth.
I managed to pair my wife's phone, and mine too.
Trouble is, eather the Kia and/or both our phones seem to forget about each other each time we hop in.
I politly ask any of them to get in touch, to no result.
I need to delete the phones from the Kia's list, then pair them again (you know, search, find, enter code...)

Any idea--or similar experience, somebody?
All two phones are Nokias, Bluetooth on permanently. I've toggled on and off the "hide-me" option. Blank.
I made sure the "auto-connect" option was validated on the Kia.
 

·
Registered
Joined
·
2 Posts
thanks for your help. i tried everything yesterday and ended up calling the kia help desk. it turns out that there's something wrong with my soul :( and that i have to take it back to the dealership to see if they can get it working.
I'm wondering if you were told what was wrong or if the dealership fixed it without a problem? I know that you posted this sometime ago but I am experiencing the same problem now. The only difference is that we had our bluetooth working for quite sometime with 3 phones successfully and then one day the call button stuck down and it switched to french and 2 days later it stopped working and started giving me this error code "system not ready. please wait a moment..." and I get it when I press the call button and when I go to the set-up. It is very frustrating. To top it off, I bought my Kia Soul from a Mitsubishi dealership second hand so I have to go to a Kia dealership to get this fixed because the Mitsubishi guys have no idea about my car... :(
 
1 - 6 of 6 Posts
Top