Kia Soul Forums :: Kia Soul Owners banner
1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hello all!

I have a 2014 Kia Soul+, and it's been acting a little sluggish lately when first accelerating. It doesn't seem to have nearly the amount of takeoff power it once did. It struggles a bit to get going and the RPM pushes up to 4000 and sticks there until you let off the gas and ease it more slowly into a higher speed.

Tonight I went out of town and used cruise control. At one point the vehicle was very clearly having difficulty trying to get back to the set speed after it dropped slightly going up a slight incline. It honestly felt like it was about to blow something. I tapped the brake, took off cruise control and eased it slowly into higher speeds after that without issue. (I should note that while it was doing this the engine oil pressure light started blinking on and off, and stopped coming on at all after disabling cruise control).

The vehicle also seems to be using oil and gas at a higher rate than is normal.

Any idea what this could be?

Thank you!
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #2 ·
I'm so sorry, I posted this in the wrong area. Meant for it to be in Gen 2 problems...Can a mod move it?

I apologize.
 

·
Registered
Joined
·
1,569 Posts
Sounds like a catalytic converter plugged up. It helps to mention what year, what engine and what transmission you have, mileage etc..
 

·
Registered
Joined
·
518 Posts
Sounds like a catalytic converter plugged up. It helps to mention what year, what engine and what transmission you have, mileage etc..
He's right. If you're using a lot of oil it's probably destroyed the converter. If your oil light is flashing....hate to say it...probably engine and new converter time.
 
1 - 4 of 4 Posts
Top