Kia Soul Forums :: Kia Soul Owners banner

1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Came on two months ago, took it to the dealer, said it was a temperature issue, but could find no problem ... and just reset it. Two months later, it is on again. Anyone have similar problem?
 

·
Registered
Joined
·
114 Posts
Need to find out what code is. Maybe thermostat is not allowing engine to get to normal operating temperature. Also could be temperature sensor.
 

·
Registered
2014 Soul+ Bright Silver (Sterling Soul)
Joined
·
785 Posts
Maybe thermostat is not allowing engine to get to normal operating temperature
Although we'll need the code number to help you further, I just read about how a stuck-open thermostat can throw a CEL as Hammerhead mentioned here. An easy check would be to see how long it takes for the engine to get up to full temp by watching your temp gauge while driving. If it takes a mile or longer, a stuck-open thermostat might be the culprit. That is unless the dealer was wrong about it being a "temperature issue". This is why knowing the code is key. The CEL is really just an idiot light for dozens of potential problems.

That said, you have a bumper-to-bumper warranty that you most-certainly paid for within the cost of your car, so make Kia fix it for you. 👍
 

·
Registered
2017 Base/auto, Shadow Black (Betsy)
Joined
·
797 Posts
Hi James3444, welcome to the forums.
Do you know what the temperature issue is related to?
Engine, transmission, exhaust (catalytic converter)?
 
1 - 6 of 6 Posts
Top