Kia Soul Forums :: Kia Soul Owners banner

1 - 8 of 8 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Good morning. I am hoping one of you experienced Soul owners might have an idea as to what is going on.
My front turn indicators are not working. I get hyper flash signal and the indicators light up solidly but do not flash. My hazard lights also light up solidly in the front while the rear lights work properly.
I've changed bulbs and cleaned sockets so suspect the issue is a relay or switch.
The problem began with only the right side at first and now both sides are failing to operate.
I am well out of warranty and have not had success looking up online schematics or manuals and even my electrical engineer partner is stumped.
Hoping to find something to try before taking it in to the dealership.
Thank you!
 

·
Registered
Joined
·
625 Posts
Have you checked the bulb holders? It may be worth exploring as another member recently had a similar issue:

 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Yes I checked and cleaned them. I am only getting a solid light on the actual turn bulbs- interior indicators are hyper flashing.
 

·
Registered
2017 Base/auto, Shadow Black (Betsy)
Joined
·
869 Posts
Hi Mims1, Welcome to the forums.

What year and model Soul are you having this trouble with?
What bulbs are you using?
 

·
Registered
2014 Titanium Stick Shift Pacific NW
Joined
·
7,440 Posts
I would check the turn signal relay. It might be bad. Also, not sure if your year had the free replacement of the lights control steering wheel stalk (doubt it's that but maybe).
 
  • Like
Reactions: Kerig3
1 - 8 of 8 Posts
Top