Kia Soul Forums :: Kia Soul Owners banner

1 - 5 of 5 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
So I seem to have an unusual problem with my built in navigation/audio system. Everytime I start the car from a cold start, it starts playing Sirius like normal (as that's my default input) but after about 10 seconds it automatically switches to AM radio with no input from me. If I swtich it back to Sirius, everything is fine. This only happens after a cold start, like after the car has been sitting for 30 minutes to an hour.

If I leave it on Radio or another input when I shut the car off it doesn't seem to swtich inputs so this only happens when I leave it on the Sirius input after shutting the car off

Has anyone had this issue before? I feel this is going be a dealer visit but just wanted to see if others had the same issue or if its a "feature" I need to find to turn off.
 

·
Registered
used to own a 2016 Soul SX 2.0L - Caribbean Blue
Joined
·
15,165 Posts
are you dealing with Scarborough KIA?
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4
Yea I am, I haven't contacted them yet due to the holidays, I was going to do it tomorrow to see though.

Thank you for the thread, I did try to do a search and though I saw other radio problems I didn't quite see this one so I do apologize for the extra post.
 

·
Registered
used to own a 2016 Soul SX 2.0L - Caribbean Blue
Joined
·
15,165 Posts
in that case you may be interested in this https://www.facebook.com/groups/135299968155/ (Soul Club of Ontario) and one of the guys at Scarborough KIA is the one that started it.

MT-ED on this forum is also a member, I have been on some of their cruises (and organized one), they are based out of the GTA and go on regular cruises and meetings in that area.
 
1 - 5 of 5 Posts
Top