Kia Soul Forums :: Kia Soul Owners banner

1 - 15 of 15 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hi all, my 2012 Soul,, the manual HVAC controls are not working. The blower motor work and I can get the rear defrost to work but that's it. No lights at all on the panel , can't switch the front defrost on, though I think thats the mode it's stuck in. No temp control so it blows hot air. I made sure the connectors to the panel are tight and checked the fuses I believe could have any effect. Anyone have a clue. Hate the idea of going to the dealer. Thanks in advance.
 

·
Registered
Joined
·
1,583 Posts
Hi all, my 2012 Soul,, the manual HVAC controls are not working. The blower motor work and I can get the rear defrost to work but that's it. No lights at all on the panel , can't switch the front defrost on, though I think thats the mode it's stuck in. No temp control so it blows hot air. I made sure the connectors to the panel are tight and checked the fuses I believe could have any effect. Anyone have a clue. Hate the idea of going to the dealer. Thanks in advance.
Check the 10A fuse in the connector to the main junction box (marked "ROOM LP").

 

·
Registered
Joined
·
1,119 Posts
Hello and welcome to the Soul forums. The Soul model will tell members what system you have .
Climate control or air conditioning.
You can update your Profile top right of page.
There is a temperature modulator on the right hand side of the unit that adjusts the hot water inlet . on the left side a modulator that operates the heaters vents.
The modulators can go wrong or the connections be knocked loose.
However if you have the full climate control system there are other sensors and also you need to read handbook to make sure you are not reverting to CC.

Jeff
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
Thanks for the reply...checked the fuses, both 20A & 10A are good. Now just noticed that the outdoor temp display is showing 3 dashes. Do you think the circuit board behind the heat & a/c controls is bad? Thanks!
 

·
Registered
Joined
·
1,119 Posts
The outside temperature display has nothing to do with heater or CC.
CC has its own in car sensors
What system have you got. ?

Jeff
 

·
Registered
Joined
·
1,583 Posts
That's odd... Some of the functions work while others don't, and all of the problematic ones go through the HVAC Control Unit rather than the BCM.

What are the resistances from pins 1, 31, and 32 from the Control Unit to ground? Pins 1 and 32 should be zero or close to it. Pin 31 I'm not sure about. It's listed as "Sensor Ground."

This could be yet another manifestation of the notoriously bad Soul grounding scheme.

By the way, there was a TSB for that unit. You may want to call Kia or a dealership and see if it was ever applied. It applied to Souls with manual HVAC controls manufactured between July 11, 2011 and June 22, 2012.
 

Attachments

·
Registered
2010, Kia Soul +, 5-spd
Joined
·
54 Posts
Check the 10A fuse in the connector to the main junction box (marked "ROOM LP").

OMG YOU GUYS ARE A LIFESAVER! I just got my car back from the body shop. They had to fix the back end from where i got hit in the back end, and the A/C was stuck on HIGH heat and DEFROST. Pulled and replaced the ROOM LP 10A fuse and Now everything is working again. I'll post some new pics of my car too! THANK YOU THANK YOU THANK YOU! (Sorry for the caps)
 
  • Like
Reactions: Buzz

·
Registered
Joined
·
4 Posts
That's odd... Some of the functions work while others don't, and all of the problematic ones go through the HVAC Control Unit rather than the BCM.

What are the resistances from pins 1, 31, and 32 from the Control Unit to ground? Pins 1 and 32 should be zero or close to it. Pin 31 I'm not sure about. It's listed as "Sensor Ground."

This could be yet another manifestation of the notoriously bad Soul grounding scheme.

By the way, there was a TSB for that unit. You may want to call Kia or a dealership and see if it was ever applied. It applied to Souls with manual HVAC controls manufactured between July 11, 2011 and June 22, 2012.
What do you mean by TBS? The link does not work.
 

·
Registered
Joined
·
1,583 Posts
What do you mean by TBS? The link does not work.
TSB. Technical Service Bulletin. Basically, instructions sent to dealership service departments, and available to others, about various issues that typically don't warrant a model recall. They may also just be informational or advisory.

Apparently there was a TSB associated with that unit, but it has since been removed from the Interwebs.

Unfortunately, I no longer own the 2012 nor have access to the service manual subscription or schematics, so I probably can't be of much help in diagnosing whatever problem you're having. This is a pretty old thread. You can probably buy a downloadable service manual on eBay, though.

Richard
 

·
Registered
Joined
·
4 Posts
TSB. Technical Service Bulletin. Basically, instructions sent to dealership service departments, and available to others, about various issues that typically don't warrant a model recall. They may also just be informational or advisory.

Apparently there was a TSB associated with that unit, but it has since been removed from the Interwebs.

Unfortunately, I no longer own the 2012 nor have access to the service manual subscription or schematics, so I probably can't be of much help in diagnosing whatever problem you're having. This is a pretty old thread. You can probably buy a downloadable service manual on eBay, though.

Richard
Richard,

Thanks for the reply. I'm having the same issues as the initial conversation starter:

Hi all, my 2012 Soul,, the manual HVAC controls are not working. The blower motor work and I can get the rear defrost to work but that's it. No lights at all on the panel , can't switch the front defrost on, though I think thats the mode it's stuck in. No temp control so it blows hot air. I made sure the connectors to the panel are tight and checked the fuses I believe could have any effect. Anyone have a clue. Hate the idea of going to the dealer. Thanks in advance.

I wonder if he ever found the solution.
 

·
Registered
Joined
·
1,583 Posts
Richard,

Thanks for the reply. I'm having the same issues as the initial conversation starter:

Hi all, my 2012 Soul,, the manual HVAC controls are not working. The blower motor work and I can get the rear defrost to work but that's it. No lights at all on the panel , can't switch the front defrost on, though I think thats the mode it's stuck in. No temp control so it blows hot air. I made sure the connectors to the panel are tight and checked the fuses I believe could have any effect. Anyone have a clue. Hate the idea of going to the dealer. Thanks in advance.

I wonder if he ever found the solution.
Without the schematics, it's tough to diagnose. I do know that that HVAC control unit directly controls many of its functions rather than going through the BCM, but I don't remember (nor have the schematics to figure out) which functions they are.

If it were my car, I'd clean the main grounds on the strut towers before doing anything else simply because there's no end to the problems those grounds can cause; so cleaning them is my first step in diagnosing all but the most obvious electrical issues. I'd remove the bolts, clean the female threads, and replace the bolts with new bolts.

If that didn't work, I'd probably wind up just replacing the whole control unit. Yeah, I'd do some diagnostics on it on the bench (again assuming I had the schematics) just for the sheer joy of it; but in the end, I'd probably wind up just replacing it rather than trying to fix it. A quick search found used ones in junkyards and eBay in the $50.00 - $75.00 range.

Richard
 

·
Registered
Joined
·
528 Posts
No lights at all on the panel , can't switch the front defrost on, though I think thats the mode it's stuck in. No temp control so it blows hot air
It's a failsafe feature. A lack of communication triggers it to keep the windshield clear of ice and snow or fog.
 

·
Registered
Joined
·
3 Posts
Thanks for the reply...checked the fuses, both 20A & 10A are good. Now just noticed that the outdoor temp display is showing 3 dashes. Do you think the circuit board behind the heat & a/c controls is bad? Thanks!
This is my exact problem!
 
1 - 15 of 15 Posts
Top