Kia Soul Forums :: Kia Soul Owners banner

1 - 5 of 5 Posts

·
Registered
Joined
·
34 Posts
Discussion Starter · #1 ·
I have 2012 Kia Soul with automatic transmission that has 114k on it. When I start moving from full stop, I'm hearing a little click sound from somewhere. I have noticed this more often when I release the accelerator than when I press it. Once it reaches 40 mph, no more click sound.

Has anyone had similar issues?
 

·
Registered
Joined
·
4,435 Posts
First thing that comes to mind are the CV joints.
Mine "click" in the morning (but then again so do my knees) when 1st getting underway.
F.W.I.W...I had also found (at 70k) a huge amount of rust had accumulated on the tops of the rotors where the vanes are and it was creating all kinds of phantom noises.
I finally had to clean the rust and it took me almost 2 hrs to get them scraped & sanded clean.
Two things to consider here...
 

·
Registered
Joined
·
3 Posts
I have 2012 Kia Soul with automatic transmission that has 114k on it. When I start moving from full stop, I'm hearing a little click sound from somewhere. I have noticed this more often when I release the accelerator than when I press it. Once it reaches 40 mph, no more click sound.

Has anyone had similar issues?
I have 180k miles on my 2012. I was hearing more like a clunking noise when shifting from people, not quite a clicking. Anyway, I changed the CV axle on the driver side and this fixed the problem.
 

·
Registered
Joined
·
34 Posts
Discussion Starter · #4 ·
Now I'm used to this sound! I will ask when I go the dealer next time. Can this be a transmission mount issue?
 
1 - 5 of 5 Posts
Top