Kia Soul Forums :: Kia Soul Owners banner

1 - 4 of 4 Posts

·
Registered
Joined
·
138 Posts
Discussion Starter #1
So the car has 170k on her now. Just relocated down south to Georgia from New England and now have a company car so no longer drive the car really. I tend to drive her once every week worst case every 2 weeks shorts trips here and there on the weekends. After about a month or so of the above she is hard to get into gear all of a sudden. Figures even surviving the cold winters of Connecticut she was fine shifting wise after a few minutes now suddenly its really hard to get into gear once moving. Red line MT-85 75W85 was put in @ 75k right after I got the car and has been fine since. Today the slave cylinder was switched out and bleed with some new fluid. The issue is the same pretty much. Before I did this I could have sworn that once she was warmed up it got a lot better but... Like I said I don't drive this car enough to remember the details! Ground where I park looks dry but maybe the transmission fluid is low anyways after almost 100k? Master Cylinder going? Let me know your thoughts. Thanks!
 

·
Registered
2014 Titanium Stick Shift Pacific NW
Joined
·
7,530 Posts
Has it ever had a new clutch or plate put in? Does the clutch pedal feel OK?
 
  • Like
Reactions: Oktavf

·
Registered
Joined
·
1,088 Posts

·
Registered
Joined
·
138 Posts
Discussion Starter #4
Original clutch, etc. as far as I know since I got it @ 74k. But good call on the shift linkage! Some silicone sprayed down there to see if it goes away and BAM problem solved! Going to put some grease in there once this stuff evaporates! :)
 
1 - 4 of 4 Posts
Top