Kia Soul Forums :: Kia Soul Owners banner

1 - 9 of 9 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1 (Edited)
Hey all - lurking poster here. :-/

Yesterday when I got into the car the audio went intermittent. At first I could get it to come back by increasing or decreasing volume. Or change a setting. Seemed to be sensitive to any changes I made. After my errand I searched on-line for hints what to try. I pulled the battery ground to do some sort of hard reset, but when I powered up the car again - no sound has come back since.

As any of you know, the system is pretty proprietary. I've found some help about amp change from jonbourg, and subsequently in the sticky thread some further wiring hints. This may come in handy. I'm just not sure if there is any known resets I can try??? I have checked what I think is the fuse for this amp... it says amp on the panel @ 30 amps. It was good. I exercised the contacts. Lacking anything, it's off the Dealer for a shock treatment (not to the car, but to me when they tell me what it might cost). This radio controls so much, so to-date I don't see any way to go to something else without serious degradation to the cars' feature-set.

Some other observations... a couple weeks ago the radio kept changing modes (switching from XM to AM). This stopped. The car has randomly dinged "5 times" when shutting off the car. Dealer is clueless to why.

Any insight is appreciated.

Roger
 

·
Registered
Joined
·
1,339 Posts
No Warranty? I read the posts about five chimes it's interesting there is no answer for it, does make you wonder if there is any connection to your problem now. As a starting point I would be looking for ground problems or some connection to the radio that is loose from the Amp.
 

·
Registered
Joined
·
176 Posts
Intermittent problems are the hardest to troubleshoot. First off where was the monkey last i.e. what did you or the dealer do last. Have them recheck their work. Also did something get wet?

No sound, but does the system power up? Does the Nav still work? If the head unit appears to work but you have no sound it may be the factory amp. If your head unit doesn't power up at all then the head unit is probably bad. Have any modifications been made to the system? If so go back over it and look at all the connections very carefully to be sure they are well connected. Look for any wiring with bad insulation.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #4
It was just in 2 weeks ago for a oil change and that steering joint recall. Trust me, being a mechanic myself, I always begin to wonder when things fail just after a service. Two or three services ago I left the dealership to go help a friend work on his Falcon and when I went to leave his place - pressed the brake, pushed the button, and NOTHING. Rinsed and repeated and it started. Took it in for that, and of course it wasn't happening so they shrugged - and I left it be until it got worse, if it did. Has only done that about 3 times.

I though the 5-ring chime was gone too with this issue, but it did it about an hour ago.

The HU and camera, UVO communications (voice recognition) bits all work - just no sound. At first it was intermittent and then after a hard reset (battery disconnected for 30 minutes) I could not get sound after. Having dealer look at it in the morning. If it is the amp and they can assure me of this... I may put my Alpine deck in following your (jonbourg's) lead. We'll see what they say, and I'll report back tomorrow. Driving these cars are tough with no sounds. They are so quiet I can hear my ears ringing (from too much loud music in my other cars...). I've wanted to up the sound in this car anyway - this may be the impetus to do so.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #5
Well... the dealer says it is the amp. They had another HU from another service job and it didn't help when they plugged it in. All the amp connections are good - so they concluded it was the amp. Now for the $64,000 question; what's it cost? Shocker - the cost for the amp is the sticker price I paid to have that entire system installed (according to the sticker sheet) and there is no way in heck I am going to pay $1400 for a new amp. No way. So, I am going to do a search for something used first I guess.

Sigh...
 
  • Like
Reactions: Soul.Master.007

·
Registered
Joined
·
10 Posts
Discussion Starter #7
Found one in CA for $150, which should be here in a few days. I did search around and found the retail on these amps are $1279 - and my dealer must feel they can round that up 10%. And found a few sites mid-$800 prices; for new. Not happy to feel my dealer is sort of taking advantage. No doubt a lot of poor souls just say "do it."

I did think hard about going the route you indicated, but I found all I have interconnected with this system would be disconnected; like, steering buttons and backup camera to name a couple. So will cross my fingers and hope this amp failure is remedied and will last until it leaves me.

But if it works I may still augment it like you did. I have a lot of high-end components I pulled from a car I sold last year (wasn't about to let all that go to someone who didn't appreciate it). The Infinity system isn't all that IMHO.

Again, fingers crossed.
 

·
Registered
Joined
·
176 Posts
Found one in CA for $150, which should be here in a few days. I did search around and found the retail on these amps are $1279 - and my dealer must feel they can round that up 10%. And found a few sites mid-$800 prices; for new. Not happy to feel my dealer is sort of taking advantage. No doubt a lot of poor souls just say "do it."

I did think hard about going the route you indicated, but I found all I have interconnected with this system would be disconnected; like, steering buttons and backup camera to name a couple. So will cross my fingers and hope this amp failure is remedied and will last until it leaves me.

But if it works I may still augment it like you did. I have a lot of high-end components I pulled from a car I sold last year (wasn't about to let all that go to someone who didn't appreciate it). The Infinity system isn't all that IMHO.

Again, fingers crossed.
Fantastic that you found one for such a good price. Hope it works out! There really weren't any out there last year. There are ways to keep the factory steering buttons and camera etc. but the factory radios in these cars seem to be pretty darn good. Augmentation is a great way of putting it. I didn't want to make too many changes because my car is a lease, but I needed more!!!
 

·
Registered
Joined
·
10 Posts
Discussion Starter #9
Happy to report my $150 replacement amp has brought sound back into the car. Hopefully this one lasts longer than 4 years!
 
  • Like
Reactions: Buzz and jonbourg
1 - 9 of 9 Posts
Top